Gopro preview live picture in RC - do's and don'ts?

Earlier I had Gopro video preview working in RC which was great to check that the Gopro was correctly aimed. But now when I click the icon in RC I don't get any preview video even though the icon turns green.

I probably have changed some video setting in Gopro that makes it work or not work?? Or could it be something else? I haven't been able to backtrack to get it work again.

Copying video files to the phone from within RC works great!

PS: Have a Gopro Hero 7 Black.


  • edited September 2019
    At least some video resolution and quality settings will prevent the preview picture.
  • Okay. Tried a bunch of settings but can't find a working one. These didn't help to get the preview back

    Video format, HEVC on or off ("Compatible" mode)
    Connect with bluetooth or Wifi password
    Protune on or off
    Bunches of resolutions and framerates. For example 1080 at different fps
    All FOV settings, Wide, Superwide, Linear
    Video stabilization on or off

    Really strange I can't get it back to how it worked fine.

    BTW: What do you recommend, connect with bluetooth or wifi password? Both end up using the wifi but are there any subtle differences between the two otherwise?
  • Try removing the battery to hard reset the camera. The internal servers are known to malfunction time to time. I will test which settings work later. Also restart the RaceChrono session to make sure RaceChrono's preview window is not malfunctioning.

    I think protune, high resolution and high frame rate will prevent preview on some GoPro models, but it all varies from camera to camera. That's why I don't know the answer before I have time to test :)

    Bluetooth is great when it works. But it does not work on all phones. That's why Bluetooth mode is not the default.
  • Thx! Will try "battery out reboot" :-)
  • edited September 2019
    "Battery out" rebooted. Still no preview. I wonder what I did, it did work earlier...
  • Phone rebooted too? Does the GoPro app get preview?
  • Yes
    I'm baffled
  • Sounds like factory reset if you cannot solve it with the GoPro app :)
  • In the Gopro app I can see the video. Always works. So when on track I start it to verify camera field of view. Then close it and start RC.

    I'll factory reset the Gopro!
  • Nope. Factory reset with default settings. Different resolutions and fps. No preview in RC.

    Also seems the Gopro doesn't like RC defaulting to 1440 (which it doesn't seem to support), the Gopro hangs on its resolution setting screen when RC has chosen 1440. When RC is set to 1080 or 2.7 all is fine.

  • Also tried 2,4GHz in addition to 5GHz Wifi. No go.
  • edited September 2019
    Interesting difference. Connecting over 2,4GHz (with bluetooth as initiator, dunno if that matters at all) instead of 5Ghz (with wifi direct connect) there is a big difference in delay when hitting the preview icon.

    5GHz wifi - hitting the preview icon it turns geen almost instantly and an all black preview "picture" appears.
    2,4GHz wifi - hitting it a text saying its connecting to preview pops up, it takes quite a while before the all black preview "picture" shows up. Seems it takes longer also on higher resolutions.

  • edited September 2019
    Please try to hardware reset and get the preview working with the GoPro app before trying with RaceChrono.

    RaceChrono does not have any settings that it would try to override by default (all settings and state come from the camera), but it may be that when changing the camera settings from RaceChrono, it puts them to some invalid state.
  • edited September 2019
    Did hardware reset of the camera, then checked with the Gopro Android app (preview worked, has never failed in that app actually) and then ran RC (no preview working, but all control of the camera, rec/stop, fps and resolution works)
  • Ah, ok I misunderstood earlier about the GoPro app. Did you do firmware update recently on the camera?

    Maybe try following:
    1) Set the camera to NTSC, 16:9, 1080p, 60fps and protune off
    2) Delete all GoPro Wi-Fi hotspots from your phone's Wi-Fi settings
    3) Add connection to your GoPro Wi-Fi from your phone's Wi-Fi settings. You'll need to enter the correct password etc. Check that the connection is formed.
    4) Delete your GoPro camera from RaceChrono settings
    5) Add GoPro camera to RaceChrono settings, disable automatic wi-fi connection, and do not select Bluetooth.
    6) Make sure you're still connected to the camera Wi-Fi
    7) Start new session and check the preview

  • edited September 2019
    Gopro has latest available firmware. Did this:

    - Factory reset Gopro, chose English and GPS on. Set to NTSC, 16:9, 1080p, protune off.
    - Deleted cache and data for the Gopro app
    - When turning on wifi in the camera a step by step wizard appears, I chose "Connect Device - Gopro app". I can't continue forward with the wizard without connecting to Gopro from the Gopro app. And canceling the wizard turns of wifi. So I connected to Gopro with the app. And then shut down the app and killed it.
    - Connected to Gopro in the phones wifi settings with the gopro name and password.
    - Added the camera in RC (the previous was deleted earlier), not using bluetooth and not automatic connect
    - Start session, RC connects to the camera, shows 1080 and 60fps correctly but all black preview. When turning on preview the icon turns green and the black preview both come on instantly. (default wifi after factory reset in Gopro is 5GHz). I can change the resolution and fps and start/stop recording from within RC.

    Sorry. I'm baffled... It did work some time back. Maybe maybe with older firmware in the Gopro but the problems with preview didn't sync with the firmware update I think. But I'm not sure. Sorry.
  • edited September 2019
    A correction for an earlier remark, Gopro of course supports 1440 but in 4:3 not in 16:9
  • edited September 2019
    - Changed to 2,4GHz.
    - Gopro set to NTSC, 16:9, 1080p, 30FPS(!) protune off.
    - Reconnected to the camera in the phones wifi settings with the Gopros password.
    - Removed previous camera and added the new without bluetooth or automatic connection
    - Start session
    - Doesn't connect (app maybe confused with new and old camera with same name are different ones. Gopro IS connected in the phone wifi settings
    - Remove camera in RC.
    - Quit RC. Kill RC. Resstart RC.
    - Add camera again like before.
    - Start session
    - WTF!???!? Preview works for a few seconds!!! Then RC looses camera and goes into "Connecting..." But Wifi is still connected in the phone settings.
    - RC is stuck at "Connecting..."
    - Quit RC. Kill RC. Restart RC. Start session.
    - RC is stuck at "Connecting..." and "Searching..." alternating
    - Power cycle Gopro with power button
    - RC is stuck at "Connecting..." and "Searching..." alternating
    - Quit RC. Kill RC
    - Disconnect ("forget") and reconnect in phone wifi setttings
    - Start RC. Start session.
    - Preview works for a few seconds. Then RC looses camera and goes into "Connecting..." But Wifi is still connected in the phone settings.
    - After maybe one half to one minute RC reconnect to Gopro. But black preview.
    - Turn off preview. Turn on preview. RC looses contact again.

    - Take out battery from Gopro, reinsert, turn on.

    - RC is still stuck at "Connecting..." and "Searching..." alternating
    - Quit RC. Kill RC. Restart RC. Start session.
    - RC is stuck at "Connecting..." and "Searching..." alternating
    - Quit RC. Kill RC
    - Disconnect ("forget") phone wifi setttings

    - Change Gopro to 5GHz
    - Disconnect ("forget") and reconnect in phone wifi setttings
    - Start RC. Start session.
    - Connection to Gopro comes up way way faster than previoulsy
    - The all black preview screen and green icon comes on INSTANTLY

    Anything you want me to try??

  • edited September 2019
    - Reboot phone
    - Connect to home wifi, not Gopro
    - Reboot Gopro with battery out
    - Gopro at 2,4Ghz, 1080 30fps
    - Start RC, remove camera. Readd using Connect wifi automatically + name and password
    - Quit RC, kill RC, Restart RC (not doing this connect will fail)
    - Start session
    - Connects to Gopro but shows 0 s remaining and no info on res or fps (I see this from time to time)
    - Shows text connecting to preview...
    - Looses contact
    - RC is stuck at "Connecting..." and "Searching..." alternating


    5GHz seems to connect much quicker and doesn't loose contact as 2,4GHz does.
    But I've only seen preview today using 2,4GHz

    Odd thing is that the previev in the Gopro app is rock solid on both 2,4 and 5GHz. But connecting to the phone can take time in the app, sometimes a restart of the app seems neccessary. But it doesn't loose contact with the camera once it's connected.

  • Good thing is that the preview is not a do or die function at all :smile: Just a nice-to-have
  • I will update my cameras and test if it happens here. I will update when I got results.
  • Oh, by the way, it's a Samsung Galaxy Note 8 I'm testing with.
  • edited September 2019
    I'm having the same problem on my Samsung S9... iPhone X and some LG phone seems to work... no idea yet why it does not work on Samsung. I'll update when I find a solution for this.
  • edited September 2019
    I've got it working more reliably, but I cannot say if it's fixed or not. But sure works better here. It will be in the next beta, so probably v6.1.1
  • Cool, looking forward to testing when you're done with 6.1.1
Sign In or Register to comment.