GPS update rate GLO 2

edited November 2021 in RaceChrono for Android

Hi, I have a GLO 2 from Garmin and there seems to be a weird update problem, which is best explained by the GPS update rate chart, as attached. It was ok for one (first) session, but 4 other track sessions were like this. I made sure to close all other apps before using RaceChrono Pro.

I also have a big (about 7-8 seconds) delay in GPS Vs obd data (it also gets out of sync over time), but that's a different problem, although I feel it's related, because it was not visible in the first session.

Any idea on what might be causing this?


For comparison, here's how it was during the first session - the refresh rate rarely dropped below 7Hz, never below 6 Hz


  • aolaol
    edited November 2021
    I think the 7-8 seconds delay is related. The Bluetooth connection is not working properly for some reason. Similar problem is quite common with the old BT-Q818XT receivers, but haven't seen it with Garmin GLO before.

    1) Which phone is it?

    2) Does your car connect to the phone using Bluetooth?

  • It's Samsung Galaxy S21 and yes, the car was also connected to the phone using Bluetooth - it didn't occur to me to try and turn off that connection.
  • @air_ii Yes, it's worth trying to disable it from the car. Also you could try if it works better without the OBD-II reader.
  • Today I've tried several scenarios, but to no avail. I disconnected everything, unpaired all other devices, but it still works that way. I reflashed firmware to the GLO, restarted the phone several times, etc. I will try with a different phone to see if the phone might be the culprit here... But it's weird that other devices work flawlessly over Bluetooth.
  • It works ok on an older Galaxy S9 phone, another Galaxy S21 unit showed the same behaviour though.

  • @aol I did some more testing this week and it looks like the issue is somehow connected to RaceChrono itself. Don.

    So I did some drives this week and only once did RaceChrono record without GPS update issues. However, I also recorded several (seven) runs with TrackAddict and there were no issues with GPS update rate at all. I cannot post pictures here anymore, but I will be happy to do some more testing/debugging to help narrow down the issue, if that's possible.
  • My phone was updated to Android 12 last weeke - don't know if that has anything to do with it, but I thought it's worth mentioning.
  • aolaol
    edited November 2021
    @air_ii I think that Android 12 might be important in solving this problem. You said you tried another S21. Did it have Android 12 as well?

    I will investigate this issue. It might take some time as I might need to wait for updates on my phones and/or purchase a new phone. But it's on top of my priority list now.
  • @aol yes, it was updated as well.

  • OK thank you. My S20 test phone is not yet updating to Android 12, and it's not guaranteed to suffer from same issue. So I just ordered a S21 to speed this process up. I'll let you know once I get to investigate further.
  • Sure, I won't be tracking my car until spring, so no rush.

  • @air_ii I've got the phone, and I'm able to reproduce it now.
Sign In or Register to comment.