Lat/Long G

Where does the lat/long G come from in RC? Is it from GPS data or accelerometers? I remember last year that there was a beta that supported internal accelerometers but I don't remember it being announced as a feature and I do remember discussion of Wiimotes!

Comments

  • aolaol
    edited August 2009
    Hi Andy, they are calculated from GPS data.

    I plan to support the accelerometers on the new S60 phones (which are at least N85, N86, N96, N97 and 5800). The old phones' accelerometers will not be supported at least at first due to much worse API (at least 5500, N95 and N82). Windows Mobile does not offer unified accelerometer API. So no accelerometer support there :(

    I had a beta supporting the accelerometers last autumn. It was for the older generation accelerometer phones. I abandoned that just because Nokia decided to change (improve) their API.

    In that beta, the accelerometer data was just logged, and nothing was done with it. Basically the new accelerometer support is in same stage, now I need to do some code that actually uses the data :)
  • Brilliant. Thanks for the update. Shame I'm running an N95 8GB, I suppose! It seems I can pick up a 5800 for about £150 on Ebay.
  • I have a 6210 Navigator, is in group of n96 or n95?

    6210 has Symbian 9.3 like N96, and 5800 has Symbian 9.4
  • Hi, yes the accelerometer on 6210 Navigator will be supported as it is S60 3.2
  • I have a problem with the display of the lateral Gs in Trackvision, as you can see here:

    Examining the csv file, the value of lateral Gs is about the half than it should be. In .vbo exports, the G values are correct. Any ideas why this happens?
  • Hi Papdoc, it's a known problem in v1.30. I've fixed it for v1.36 beta. I'm assuming you're using Symbian, so please join the beta group if you want to test it (check news for details).
  • Will do, thank you!
  • The lateral g problem is fixed in the beta version! Thanks a lot!
    Here is a comparison video of v.1.40 vs v.1.30:
  • Thank you for testing it!
  • I run a nokia e62...is this a `consistant issue?

    Is it safe to say all exported .csvs from rc up to 1.36 have incorrect low g data?

    while we are on this..a g filter on export would be nice to stop the erroneous spikes
  • aolaol
    edited February 2010
    I fixed this problem for 1.35 beta. So all CSV exported with 1.30 or before had wrong Lateral-G value. There is 4G filter in place I think.
Sign In or Register to comment.