Known bugs for the Android version

Notice: If you're getting crashes on your phone, Android system will ask you to submit a crash report. Please do so, because then I can instantly see the stack trace of the crash!

This is the current bug list for v2.20. Note; This thread is now closed, so If you have a new bug, please create a new thread for it (if similar thread doesn't already exist).

The bug list
- App crashes when opening a library track, and pressing back immediately
- No trap/split labels on .CSV exports
- Problems with .CSV exports, for example RaceChrono2AVI is giving different lap times compared to RaceChrono

Not bugs, but important stuff I did not have time to do yet:
-• Performance testing
-• Editing session name and description
-• OBD-II and RaceDAC support
- Missing importing (NMEA etc)
- Missing raw NMEA saving while recording


  • edited February 2012
    hi aol,
    It is not important but I wanted to report it :
    I do not yet have android phone ... but i have an android notebook. This is the Toshiba AC100, the Android version is 2.2 (kernel This notebook has no internal gps and no bluetooth. It has a USB port and WiFi. It does not have access to the android market.

    RaceChrono preview apk will not install on this hardware. (Yes I checked 'Settings > Applications > Unknown sources' is enabled.)
  • hugos: this is the reason you can't install it: Package requires unavailable shared library; failing!
  • edited July 2012
    I have been using racechrono since you released it for android, and it works quite well. Except for the connection between my phone, HTC Wildfire, and the GPS device I am using, iblue 747 A+. They connect together at the begining of the session, most of the time I get 10 satellites, my phone starts recording, and at the end of the session when I look at the screen it says "no gps connection". I guess the bluetooth connexion between the devices gets lost and they cannot connect again. It's really annoying because when it works the lap times are very accurate as well as the map.
  • Fred, what happens when start a new session after "no GPS connection"? I have one phone (ZTE Blade mk.1) that crashes Bluetooth Stack and cannot reconnect before re-boot... If this is the case with your phone, there's really not much I could do.
  • When I start a new session it works very well. That only happens from time to time. No need to reboot the phone either. I have downloaded the 2.06 version this afternoon, before I had the 2.00.06 (the very first one), I'll let you know how it works next time I use it.
  • Hi aol, like to say what an awesome program, much better than Trackmaster which is not very accurate in recording tracks (constant zig zag recorded even when travelling in a straight line). Racechrono gives me what i expect to see eg. straight line when i have travelled in a straight line.
    I am having a problem with recording at 10hz, its missing data. From research, I found comments talking about Cpu speed in phone not up to the task and got the impression(Trackmaster Forums) you need at least a 1Ghz Android Phone for reliable 10hz data logging.
    I beleive this is not the case as i was originally using Racechrono on a HTC Wildfire 600Mhz CPU which would not give me reliable 10hz recording (work phone), i have since purchased a Samsung Galaxy Player 4.0(1Ghz CPU) hoping it would be able to record at 10hz. I was suprised when i couldnt log 10hz without missing data from the Samsung.
    I could do 5hz perfectly on the HTC and the Samsung. After hours of playing around myself trying to get it to record at 10Hz. I managed to do it but only if i unpair Qstarz BT-Q818XT from my phone, start racechrono, press start to begin logging and then it pops up asking for me to pair Qstarz to the phone and enter number, i do this then racechrono records perfectly at 10Hz. The strange thing is after i worked this out i tried the same procedure on my HTC and it recorded 10Hz perfectly as well. If i stop recording in Racechrono then start recording again without unpairing it goes back to missing data at 10Hz. This only works if i do the pairing in Racechrono, if i do the pairing in the bluetooth system window then start racechrono it doesnt work. I have tested this a lot and it will only reliably log 10Hz if i go through this procedure every time, 5Hz works as expected on both phones

    I realise it may not be a problem with Racechrono but was hoping for your thoughts on this.
    Samsung Galaxy Player 4.0(rooted and custom kernel/rom) 2.3.5 Gingerbread
    HTC Wildfire (stock) 2.3.5 Gingerbread
  • Hi Aol, i have done some more testing and it's not related to racechrono.I tried another very simple app to record the NMEA data from the qstarz bt-q818xt and it gave me the same results eg. i could only reliably log 10hz by starting the app unpaired then when asked to pair with qstarz (in the app) enter number and it logs 10hz perfectly. 5hz works no problem. Hope this is of some use.

    HTC Wilfire 2.3.5
    Samsung Galaxy Player 4.0 2.3.5
  • Ran RaceChrono on the weekend at Phillip Island. On the first day of racing, ran my old Samsung Galaxy S i9000 with just the internal GPS sensor, as I forgot to take the QSTARZ down to the track. On the second day, I used the QSTARZ at 10hz all day, and the timing was super accurate. However, the speedlog is extremely jagged and all over the place using the QSTARZ, where as its smooth on the internal GPS. Is this simply due to the increased refresh rate? It was sunny all weekend, no clouds around, so got me buggered as to why my speed down the straight wasn't just gradually increasing according to the QSTARZ log. Any ideas?
  • edited September 2012
    cjhod1: Analyzed your session, and seems like you're experiencing same problem as mrexcitement: The GPS seems to run out of buffer, so you get .1 .2 .3 .4 .5 updates for a second, and then maybe .3 .4 .5 updates from next. So you're missing lot of data. Please switch it to 1 Hz (so RaceChrono will actually use it as 5 Hz), and see if the speed data seems better at all.

    Meanwhile I will try to reproduce and fix the issue.
  • Hi, I've just downloaded the latest android version (using on an HTC) and am still having trouble with the download function. When downloading to .csv the times for laps when viewed in RaceChrono2avi are faster than they are in RaceChrono?

    I am exporting sessions recorded with the previous version.

    Is this still an issue?

  • edited February 2013
    Steve, unfortunately I didn't have time to touch exporting at all. Is it possible that you would send the session in question to me? I don't mean the .cvs, but the actual session directory under /RaceChrono/session-*. The session directory will have same name body as the .csv you're having problems with. So, please make a .ZIP out of the session directory and send it to me to tracks(at)
  • Ok, thanks. I will zip that and send it across to you.
  • Sent, thanks.
  • This thread is now closed, from now on please post new thread per every new bug you might find!
Sign In or Register to comment.