RaceChrono on android head unit

edited June 2013 in RaceChrono for Android
I am fairly new to this android stuff but have RaceChrono running fine on my tablet.

I have installed in my car an android head unit T7019A from Tradesolution HK http://www.tradesolution.hk/e/ptxwebstore_product/1274.html

Head unit is running android 2.3

In google play race chrono doesn't show and from the web install it comes up with the 942 error. Have stopped and cleared data and cache from play store but still no luck.

Am I able to get the latest apk file to try out?

I've paid my VIP membership so I don't feel guilty asking!


  • edited June 2013
    Hi, I've just emailed the APK. In order to install you need Google Maps etc. to be installed. Cannot guarantee it will work on this fairly rare Android device, but I guess it's worth trying :)
  • Thanks! Also have the old version apk so fingers crossed.
  • Damn, doesn't seem to be compatible. Installed google maps then tried the apk you emailed as well as the old apk I found on your forum here and both go through the installation process fine but then simply say "application not installed".

    Doesn't seem to be compatible for some reason even though it is running android 2.3.

    Any ideas?
  • Not sure what's going on as the package manager doesn't have error code 942. Would it be possible for you to connect the device to ADB to get the debug log http://developer.android.com/tools/help/adb.html ? Most probably it is missing the correct version of Google Maps APIs. Are you able to run any other app that has maps in it?
  • Sorry @aol I don't understand what you mean?

    Are you able to tell me exactly what I need to do as I'm new to this android stuff. I followed that link but it has a whole heap of stuff I don't understand.

    Do I need to download a file that will produce an error log that you can view?
  • edited June 2013
    nzer, basically you would need some Android skills to dig it up. Much too hard try to explain how it works (other than referring the google documentation). But basically you'd connect the device to computer with USB cable, would setup ADB drivers etc, and then use the ADB tools to extract the logs from the failed install event. http://developer.android.com/tools/help/adb.html#logcat explains how to do it
  • Thanks. Beyond me @aol so will just have to forego RaceChrono damn it.

    Wanted to avoid having to have my iPhone in the car with the android head unit.

    Might be something to do with google maps. Can't seem to sign into The maps app. It says login failed when I go into it even though google account is selected in play store and on google in browser.
  • edited June 2013
    nzer, yeah it's quite hard with these Android devices that do not pay royalties to Google... They advertise Android but not all apps work because missing Google apps and libraries. I had the devices, I could make a version of RC that would work with it, but it's really not worth for me buying there rare devices, that only so few people will use.

    I can make a version that does not require Maps at all at some point. But right now I'm too busy with the next version that has OBD-II etc.
  • I have a mate that has been looking into this issue for me.

    He says
    "I think I have a lead on the RaceChrono issue.It sounds like I suspected - I just have to figure out how to solve it. If you are in contact with the RaceChrono group, you might want to send them the following link and see if they can make a version for you/us/others that uses OpenStreet Maps instead of the Google Maps API. I believe we are missing the com.google.android.maps framework because we aren't google certified. Strictly speaking, we shouldn't even have Google Play installed! In the app's manifest file it states that it has a dependency on this framework, which the installer checks for (and fails)."


    Are you able to look and see if you can do something for me about this please?

  • It's a bit larger problem as I was already (or thinking of) relying on Google Sign-in, In-app purchases etc, which are all Google certified APIs... What I would need to do to support these devices is a completely separate 'non-Google' app. It would be lot of work so this is something I need to consider carefully, if it actually would be worth the effort.
  • Yep, absolutely understand that. Guess the more Chinese knock-off tablets, phones and head units out there the more people that will want this.

    As mentioned I don't know much about Android but I thought the big selling point was the operating system not being reliant on proprietary stuff (like Apple). Seems though if apps are reliant on things like Google then it is not as "free" as I thought it was.

    These head units like the T7019A are one of the few ways to have a rooted device in a car to run Bluetooth from the OBD2 port so are becoming quite popular. Running Torque or Carscope is great but being able to run RaceChrono would just make it the perfect solution.
  • edited July 2013
    You're absolutely right about the Chinese non-Google android devices. I will just have to think the right strategy to approach this. Cannot promise ETA or give any details, as I need to think this through, but I see the wider need for this now.
  • Thanks for considering it
  • edited July 2013
    @Greenpants on the FT86club forum has posted a fix for this. Problem is a couple of files that are missing on the android head units. Greenpants has actually created a new system.img file that fixes it when rooting the device but assuming the device s already rooted his solution is below.

    Wonder if as part of installing the app somehow it could check if these files are present and install them if not. Probably not as might require root but thought I'd let you know I now have RaceChrono running on my android head unit after this fix.

    Link here

    Actual post is:
    *** Insert standard disclaimer here. If you don't understand what this is doing, you probably should be doing it. If you do it wrong, there is the possibility you could 'brick' your unit. Make sure you have an emergency Android geek on standby - just in case. ***

    Summary for android experts (post link above has step by step for noobs like me)

    Download the correct version of http://wiki.cyanogenmod.org/w/Gapps
    For Gingerbread (2.3), use the http://goo-inside.me/gapps/gapps-gb-20110828-signed.zip

    Extract the following files to a USB stick:


    On the Android device, mount /system with r/w privs
    copy .jar file to /system/framework/
    copy .xml file to /system/etc/permissions/
    Remount /system with r/o privs again
    Perform a (soft) reboot

    The, should be able to install the RaceChrono apk. Still wont install from the play store but the apk will install.

Sign In or Register to comment.