WM 5.0 Internal GPS problems (RaceChrono does not work)

Hi Guys, I'm a n italian user.
I've istalled this program under WM 5.0 in my HTC p 3300.The programs looks like if it's all ok, but when i start a new session simply the prgram is not able to "take" the signal of gps.
Appears the message "No fix to satellities"... what can I do?
The Internal gps i well-configurated, and the port is the right one...
I tried in the same position to navigate with TomTom, and he take the signal quickly...but with Racecrhono it wont.
Thank you for helping me, if you have any question let me know.


  • edited June 2009
    Do you get anything to <your selected storage>\RaceChrono\Sessions\*-nmea.txt files? Are they 0 bytes or do they have content?
  • I have three txt fils, they 0 bytes.
    I have other six unknow files all of 16 and 84 bites.
  • Seems like the port is wrongly configured, if you're getting 0 bytes in NMEA. What are your configurations in "External GPS" in the Windows Mobile settings?
  • My Pocket Pc has an Internal GPS receiver, I haven't an external one.
    If I browse My PPC and I go to Gps->Settings I have two menu:
    The first one, named "Program", Is configured with software port COM4, the same that I put in TOMTOM Navigator, and it works.
    The other options, named "Hardwar port", has the space is "empty"...shouId assign an Hardware Port?And wich one?
    Sorry for my bad english :(
  • Edit: Looking on google, I've found that the Hardware Port Must be empty if I use the internel receiver.
  • Sorry, the settings are a bit different in my WM 6.1 devices. I don't know why it's not working... I will try to get a WM 5.0 device with internal GPS to test.
  • Hi racefans,

    I have the same problem like Zealot87. I´d istall the software on my htc (xda) with intergratet gps receiver. TOMTOM is working perfektly. If I use an external bluetooth gps receiver it works perfektly, but with the integratet gps receiver I get the same message like Zealot87 "No fix to satellities"....?
    Please we need help.... ;-)
  • What are the exact GPS settings you use in TOMTOM?
  • I have HTC P3300 WM 6.0 and the same problem. "No fix to satellities"...
    TOMTOM GPS setting is "internal GPS receiver"
    I have tried several other GPS software with no problems and GPS settings are simply software port COM4.
  • edited June 2009
    Certainly there is a problem with the internal GPS through COM ports. Thanks for everyone for reporting!

    I will take a look at this when I get my #1 laptop back from maintenance, that has all the windows dev stuff. RaceChrono does not support the "GPS managed by Operating System" in WM, but yes, they should work through the COM ports.
  • edited June 2009
    Works for me with External GPS

    I bought a Dell Axim x51 PDA (just for this so my friends don't crash on the racetrack with my Nokia phone) it run windows mobile 5.0 OS

    The following is a guide to setup a bluetooth GPS receiver on windows mobile 5.0:

    STEP 1
    Go to Settings >> Connections >> Bluetooth
    Turn it on then go to >> Devices >> New Partnership...
    It will find your bluetooth GPS select that
    Select the Serial Port and Save
    then go to >> COM Ports >> New Outgoing Port
    Select the GPS Device >> Next
    Select COM Port, I chose COM7 >> Finish

    STEP 2
    What you need to do is go to Settings >> System >> GPS
    Programs tab GPS program port should say (NONE)
    Hardware tab GPS hardware port: Select COM7 (or the one you selected in the previous step)
    Baud rate 115200
    then done:

    STEP 3
    Racechrono Settings >> GPS receiver >> GPS type: Serial port GPS
    GPS serial port: Select COM7 (or the one you selected in the 1st step)
    GPS baudrate: 115200

    You are all set
  • edited July 2009
    RaceChrono v1.30 supports now Internal GPS setting which means no COM port configurations needed anymore to use the Internal GPS! Just switch your Settings > GPS > GPS Type to "Internal GPS".
  • Thank you. With new version finds gps quickly and program himself is also feels faster. I have new issue, when phone is going "sleep mode", then is no data recording. All other programs like TOMTOM or Garmin are preventing phone to go sleep mode.
  • edited July 2009
    Hello Risto, great to hear the Internal GPS setting works for you. RaceChrono (tries) to prevent sleep mode when you are in "Live Timer". Otherwise sleep mode is allowed. Did you try the "Live Timer"? What phone are you using?
  • I have HTC P3300 WM 5.0 and tried to use "Data logging" to see how its works
  • Did you try "Switch to Live Timer" from the session menu? The lights should not go out while in there.
  • Doesn't work for me with HTC P3300 WM 6.0. I tried the new version with Internal GPS settings but the result is the same with COM port setting. It doesn't find any satellites all I get is "No fix to satellities"
    Anybody got this working with WM 6.0 and internal GPS?
  • edited July 2009
    Jay, works on my WM 6.1 HTC Touch Diamond. Don't have 6.0 with Internal GPS here, but it should work just fine.

    Go to your chosen storage location and open the RaceChrono\Sessions folder. Do the *-nmea.txt files contain anything? If you have used Bluetooth GPS prior this, then try to select files that are recorded with the Internal GPS setting.

    It might be just that your GPS is not locked to satellites ...
  • -nmea.txt file is empty. No I haven't used any Bluetooth GPS.
    TOMTOM and other GPS software I tried locks to satellites in just few seconds.

    Maybe I'm just doing something wrong.
  • edited July 2009
    Ok, just wanted to make sure it's not reception problem. As the file is empty there is probably still something wrong with how I use the API. I would have to do testing at the actual phone, but I don't have any older HTC's with me on my vacation. I will get back to this early August, I hope you can wait.

    It's quite odd that the it works same device on WM 5.0 but not WM 6.0... anyone else having this problem (or anyone if it works with HTC P3300) please reply!
  • Hi,
    I tried today with my HTC P3300 WM5.0 several modes, "data logging" and "Performance test" and works perfectly. :) Thanks for aol good hint "Live timer" and no problem that phone goes sleep mode!

    I made also small test video and now I am trying to put video and RaceChrono2AVI together. Unfortunately no success yet :( I think that I don’t have proper program, if someone can help me with this. Thank you forward !
  • edited July 2009

    I have a P3300 WM6
    All -nmea.txt files are 0Kb...

    How can I help?
  • OK, the internal GPS does not work for you either. Like I said, I will take a look at this after my holiday. I might send you some test versions then.
  • Ok thank you Aol... i'll try this new version in a while, and i'll report if it works !
  • Ok i've tested... now the program works fine!
    It fix to satellites in a while, and the signal is strong.
    Another Question: I've tried to do a performance test of 0-100 kpn, can you please tell me where are the results?Are they in to <your selected storage>\RaceChrono\Sessions\*-nmea.txt files?
    And how can I open this kind of files?If i open with a txt reader they appear just like random number and letters.
    Thank you in advice.
  • Did you try to open the "Runs" from the session menu? You should see the results there.
  • Yeah I can see the results in "Runs", i would know if is it possible to export in a file for home-pc.
    By the way, now the software works fine, and it's very cool... i tested some performance test, wow ...
  • Not possible to export times yet, but there has been requests for this so I guess I need to do it :)
Sign In or Register to comment.